[]

excel'de birbirinin negatifi olan sayıları bulmanın kısa yolu var mı?

Mesela 1 ve -1 ise tak diye bulmak istiyorum




 
sayı serin a2'den başlıyor diyelim. yan kolununa =abs(A2) yap aşağı kadar çek, sonra filtreleyerek istediğin rakamı ara, veya koşullu biçimlendirme yaparak renklerindirerek bak çok yoksa, hiç olmadı veri çok fazlaysa iki kolonu pivot yapıp row kısmına abs kolonunu koyarak pivot tablo oluştur.


  • cokponcik  (22.07.21 12:09:17 ~ 12:17:11) 
if(a1 x -1) = b1 > TRUE yazdirirsan, TRUE lari filtreleyebilirsin.


  • acan99670  (22.07.21 12:45:57) 
C1'e şunu yaz.

=IF(A1=-B1, "Evet", "Hayır")
  • vatanperver  (22.07.21 12:47:18) 
Anlatamadım tam, iki farklı row'da değil tek row'da 5000 line arasında arıyorum bunları. Atıyorum -5241 A1'deyse A2756'da 5241 varsa onu bulmak istiyorum


  • noluyo yaa  (22.07.21 13:04:08) 
Eğer -5241 ve 5241 değerlerinden o sütunda birer adet var ise yan sütuna bu sütunun mutlak değerini alıp ( =MUTLAK(A1) formülü ile) Koşullu biçimlendirmeden yinelenen değerleri vurgulayabilirsin.


  • himmet dayi  (22.07.21 13:37:17) 
@himmet dayi, maalesef birer adet yok. Hep kendini tekrar eden sayılar.


  • noluyo yaa  (22.07.21 13:50:01) 
Öyle ise B sütununa benim dediğimi yapıp C sütununa da

=EĞER(A1=B1;;"negatif") gibi bir formül eklersin. Negatif yazan hücreleri de yine koşullu biçimlendirme ile boyarsın. B ve C'nin aynı anda boyalı olduğu satırlar 'pozitif yineleneni olan negatif değerler' olur.
  • himmet dayi  (22.07.21 14:27:27) 
1
buraya yazılanların hakları Sir Anthony Hopkins'e aittir.
yazan eden compumaster, ilgilenen eden fader
modere edenler angelus, Artibir, aychovsky, baba jo, basond, compumaster, deckard, fader, fraise, groove salad, kahvegibi, kaymaktutmayansicaksut, kibritsuyu, monstro, pandispanya, robin, ron dennis
bu sitede yazılanların hiçbiri doğru değildir. site içeriği küçükler için sakıncalı olabilir. yazılardan yazarları sorumludur. kaynak göstermeden alıntılanamaz. devlet tarafından atanmış bir kurumun internet üzerinde kimin hangi bilgiye ulaşıp ulaşamayacağına karar vermesi insan haklarına aykırıdır. web siteleri kullanıcıların istekleri doğrultusunda bağlandıkları yerlerdir. kullanıcılar isterlerse bir web sitesine bağlanmayabilirler. bu güçleri ve imkanları mevcuttur. bir kullanıcı bir siteye bağlanmak istiyorsa bu onun tercihi ve hakkıdır. bağlanmak istemiyorsa bu yine onun tercihi ve hakkıdır. halkın kendisine hizmet etmesi için görevlendirdiği kurumlar hadlerini aşıp halka neye ulaşıp ulaşmayacağını bilmeyen cahil cühela muamelesi edemezler. ebeveynlerin çocuklarını sakıncalı içeriklerden koruması için çok sayıda bedava ve ücretli yazılım mevcuttur. bu yazılımlar bir web tarayıcısını kullanmaktan daha karmaşık teknik bilgi gerektirmemektedir. devletin milletini küçük düşürmesi ve ebleh yerine koyması yasaktır. Skimlinks ile linkler üzerinden yönlendirme payı alınmaktadır.